Review: Terraforming Mars


#61

I’ve accepted both invites. The first was gone when I checked back though.


#62

I received a red badge and a notification on my lock screen saying I had an invite. When I opened the app, however, I cannot find anything indicating that there’s an invite to accept. I’ve looked everywhere. Am I missing something, or is it disappearing?

Do you mean I have to log onto the website to add friends? I cannot do it in-app?


#63

Gosh but this is exciting.

Yes, you have to add players to your buddy list at the website. You cannot do it in the app.

I found a Neumannium and a Neumannium1 at Asmodee. Neumannium was last seen playing Terraforming Mars on June 10 whilst Neumannium1 had not been seen since 2017. So I chose Neumannium as my buddy and he was sent the invites.

You got told you had an invite so it seems I picked the right Neumannium. But you cannot find it … so ??? My other games have started without a hitch so something weird is afoot.

If you have the energy try adding “hardco” and “robthomasson” as buddies at Asmodee and inviting us.


#64

:exploding_head:


#65

There is this … Guide at BGG.

As some comments say, everything is dependent on the situation but a starting view of the value of things is useful. The learning in the game is getting to know the types of cards and getting a feel for their value rather than learning a strategy as in, for example, a tried and trusted set of opening moves. So … play more games!


#66

Weird that the invite is disappearing, @Neumannium. @robthomasson, @geigerm and I have started a second game and we haven’t had any real problems.

Some oddities, (like sometimes having to choose cards in order), but not too many issues so far.

I still wish that notifications would show which games you have a turn in, as that part is really annoying. But now that I only have one active game, it’s not an issue.


#67

@Neumannium I have accepted a game invite from @hardco and I see that there is another player invited who has not yet accepted. Guess that is you.

Looking back up the thread and seeing that you are on iOS beta version 1.0 (611) - whilst I and all others who declared are on 1.0 (518) - may be a clue to why “you are different” if you still have no invite.


#68

Yeah, I keep getting notifications that I have an invite waiting, but when I open the app there’s nothing there. It’s either because I’m on a different version or I’m looking in the wrong place to accept invites.


#69

It must be your version. Thank you for trying and sorry for your wasted time.

I was wrong about invites having to be accepted in order … it seemed like a possible reason but it was a memory from another game app. I sent a Mars invite yesterday and the last player to be invited accepted whilst I was still online and that position was filled in on my screen straightaway.

@Hardco suspects that invites have to be accepted in a fairly short time … so, to be safe, if you ever get to our version and send an invite … let us know!


#70

This probably has something to do with why you aren’t getting updates for the iOS beta:


#71


#72

Indeed. TestFlight says my iOS beta copy will expire in 8 days. Steam will still sell me a PC copy.

@whovian223 You have it on Steam. Allegedly. Might I ask … is it essentially the same as on iOS barring “obvious” platform differences. And is (maybe soon to be was) it cross-platform?


#73

I wonder if it’s far enough along that Asmodee will shop it to another dev?


#74

Damn.

Servers appear to be down as well.
What will happen now?

It’s too bad because despite the huge slowdown in beta progresses the app was really well made but some async quirks (which worked fine and was fun tbh anyway).


#75

Well, that’s a kick in the teeth…


#76

I took my turn this morning, so the servers must be back up.

That royally sucks, though.

@robthomasson the Steam version doesn’t have notifications that I’m aware of, and since our games are on the beta, I can’t see them when I log into Steam

But ultimately I would assume it’s the same build


#77

Asmodee? The publisher I most associate with some guy shrugging his shoulders and saying “eh, good enough?” Well, one could hope…


#78

@whovian223 Thank you. And … d’oh! … of course, iOS beta, Steam production.

@Pitta Servers up at the moment so (hopefully) you caught a glitch.

As for what happens now … probably starts with who has what rights, what the actual deal was with LuckyHammers. He said … seemingly wisely but actually unhelpfully,


#79

Oh my…

This happens wayyyyy too often.


#80

New beta just dropped into Testflight - 1.0 (611)